ac97 sound device not detected (alc655 codec)

Vincent vs1 at
Thu Jan 4 07:58:05 PST 2007

On 2007-01-04, Gergo Szakal <bastyaelvtars at> wrote:
> On 04 Jan 2007 03:05:58 GMT
> Vincent Stemen <vs1 at> wrote:
>> Hi.  Are there any known bugs in detecting ac97 sound devices?  It does
>> not detect ours at all.  We tried on the 1.6.0 kernel and on the
>> 1.7.0-preview from CVS yesterday.   We loaded snd.ko module manually and
>> also tried loading snd_pcm with loader at boot time.  If I understand
>> correctly, snd_pcm is the one that handles the ac97 devices.   
>> Every time we load the snd module, we also get this error
>>     fdc0: cannot reserve interrupt line
>> printed about 6 or 7 times to the system log
>> When I cat /dev/sndstat, this is all I get:
>>     FreeBSD Audio Driver (newpcm)
>>     Installed devices:
>> The sound works fine on NetBSD.  NetBSD reports that it is an ALC655
>> codec using IRQ 10.
>> We looked in the sys/dev/sound/pcm/ac97.c file and that codec is listed
>> in the ac97_codecid structure.
>> Any suggestions?
> We have to know the type of your card (pciconf -lv can be your friend), and you have to load the module (=='driver') for it anyway (for my i810, it's snd_ich).

Thanks for the reply.  As I mentioned, we loaded snd.ko, which loads all
the sound drivers, and it was not detected.  Here is the output of
pciconf -lv.

none2 at pci0:17:5:        class=0x040100 card=0xa0021458 chip=0x30591106
rev=0x50 hdr=0x00
    vendor   = 'VIA Technologies Inc'
    device   = 'VT8233/33A/8235/8237 AC97 Enhanced Audio Controller'
    class    = multimedia
    subclass = audio

More information about the Bugs mailing list