ISO images larger than 2G via vn(4)?

YONETANI Tomokazu qhwt+dfly at
Fri Jan 19 23:32:21 PST 2007

While trying to set up an openSuSE installation source for my office,
on a DragonFly 1.6.1-RELEASE machine, I noticed that I couldn't access
part of files on the image because of `File too large' error.  I tried
using DVD image which can be downloaded from one of the following mirror

  Mirrors Released Version - openSUSE

You can mount this image using vn(4):
  # fetch http://.../openSUSE-10.2-GM-DVD-x86_64.iso
  # vnconfig -c vn0 openSUSE-10.2-GM-DVD-x86_64.iso
  # mount -tcd9660 /dev/vn0 /mnt

The size of the ISO image is 3.7Gbyte, so I thought it either a limitation
of cd9660 filesystem, or a signedness bug which has been sitting around
since FreeBSD 4.8 .  However, when I tried the same image(MD5 sum matches)
on my home server(running DragonFly 1.4.4-RELEASE), I didn't hit this
problem.  In fact, I get no errors when I do this on 1.4.4:
  $ find . -type f |xargs md5 -r >/dev/null

but I do on 1.6.1 or HEAD:
  $ find . -type f |xargs md5 -r >/dev/null
  md5: ./media.1/directory.yast: File too large
  md5: ./media.1/ File too large
  md5: ./media.1/media: File too large
  md5: ./media.1/products: File too large
  md5: ./media.1/products.asc: File too large
  md5: ./media.1/products.key: File too large

I also tried a UFS filesystem using vn(4) on a machine running HEAD,
and cp'ed some big files which are more than 2G in total, but
I got no errors:
  # dd if=/dev/zero of=3G bs=1m count=3072
  # vnconfig -c -s labels vn0 3G
  # disklabel -r -w vn0 auto
  (edit it to create an 'a' partition)
  # newfs /dev/vn0a
  # mount /dev/vn0a /mnt
  # cp -r /home/dumps /mnt

  # find /mnt -type f |xargs md5 -r

so I think it's not a bug in vn(4), but it must be in cd9660(4).


More information about the Bugs mailing list