Page fault when booting an old Pentium machine

Antonio Huete Jimenez tuxillo at
Sat Dec 8 00:44:14 PST 2007

El Fri, 07 Dec 2007 14:47:40 -0800, walt escribió:

> Antonio Huete Jimenez wrote:
>> El Fri, 07 Dec 2007 12:43:13 -0800, walt escribió:
>>> On Fri, 7 Dec 2007, Antonio Huete wrote:
>>>> Hello
>>>> Today I installed DragonflyBSD on a old Pentium I 75Mhz with 32MB EDO
>>>> RAM to see what happens. I first installed harddisk on another
>>>> machine, when DF installation procedure ended I installed the
>>>> harddisk on that old machine :P
>>>> And what happened is that it doesn't boot at all :-(
>>> That *is* an old one.  What cpu options did you build the kernel with:
>> Hello Walt
>> I didn't build the kernel since it's a clean install. AFAIK Pentium I
>> cpus are I586, correct me if I'm wrong.
> Right.  It was supposed to be named the 586 but trademark lawyers nixed
> that idea.
> Well, no one else is asking questions yet, so I'll ask some random ones.
> Have you tried booting with ACPI disabled?  (See the DragonFly boot
> menu.)  Do you have LBA enabled in your BIOS?  Does the machine have a
> CDROM or even a floppy disk drive?  You might try booting the install
> disks from FreeBSD or NetBSD or Knoppix just to see what happens.
> Oh, and did you try booting that hard disk in the original machine you
> used to install DFly?
When booting DragonFly I have tried all the options in the menu, but no 
one of them succeed, I keep getting same error. This BIOS is too old, it 
doesn't have LBA. Machine doesn't have neither CDRom nor floppy drive and 
the BIOS doesn't leave me the choice of booting from CD.
Dragonfly booted fine on the Pentium II I installed.

If you need some more information, please let me know :)
Antonio Huete

More information about the Bugs mailing list