not always reproducable installer problem

Matthew Dillon dillon at
Tue Aug 28 15:08:22 PDT 2007

:Justin suggested I send the details to this list. dmesg from the two 
:affected systems follows. 1.8.x installs fine on both and ad0 is probed
:correctly. 1.10.x installed on neither system last week but installs fine on
:same hardware today, though ad0 probes with an error.
:Now I'm perplexed as I can't reproduce the error on the same hardware and am 
:trying to figure out what factor(s) caused the original failure.
:Last week when I tested, both 1.10.0 and 1.10.1 started acting weird as soon as 
:I typed "installer" and went to the "GUI". It would hang for a minute just 
:before asking for the language. In the Select Disk screen, ad0 showed as 
:still happens while 1.8.x on the same system correctly probes ad0.)
:However, last week fdisk would fail, and always at 81% I can't remember the 
:exact error message, something about a wrong boundary and the error is 
:different than the one you get if you accidently try to fdisk acd0. This was
:the error I tried reproducing last night and this morning--but now fdisk works. 
:Also, last week, I could not get past this error, even if I tried booting with 
:ACPI disabled or in safe mode--fdisk always failed at 81%. Also, if I retried 
:fdisk, I'd cause a kernel panic at around the 4th retry.
:I thought perhaps it was because Ubuntu and grub were installed on the system 
:previously and this confused the installer. So I reinstalled Ubuntu, then 
:dragonfly, but still no error.
:Now I am trying to think what else I've done differently...

    There are several possibilities.  It could be a driver issue (1.8 used
    the original ATA driver while 1.10.x uses NATA), but driver issues
    usually have more consistent failures.

    It could also be cabling or heat related.  I noticed that the driver
    connected to the drive at UDMA100.  Is this an old machine?  Is it a
    laptop or desk top?

    Getting stuck for long periods of time between menus sounds like it
    is having problems accessing the CD, but that would make it more likely
    to be a driver issue since the two are on separate cables.

    You might be getting some meaningful messages on the error console,
    which you can flip to from the installer using ALT-F1, ALT-F2, ALT-F3,
    etc.   Errors are logged to one of those (I forget which).


More information about the Bugs mailing list