[issue784] SATA no-go on ATI SB600 (K9AGM-FID)

Joe "Floid" Kanowitz sinknull at crater.dragonflybsd.org
Wed Aug 22 00:07:25 PDT 2007

New submission from Joe "Floid" Kanowitz <jkanowitz at snet.net>:

I mentioned this on IRC a few days ago, and got as far as confirming it remains
a problem with 1.10 (well, "1.11") as well as 1.8.

I now have a few SATA devices at my disposal, including the aforementioned PATA
bridges and a native SATA Lite-On DVD burner.  All SATA devices are detected
properly by the BIOS, none by the kernel.  

When I had a bridge installed on the HD, the system could boot up until it tried
to mount root without a root device.  

Out of BIOS options of "Native IDE," "Legacy IDE," AHCI and RAID, I've tried the
first three and believe I've left it on Native IDE for now.  

IIRC, the "Legacy IDE" option would tend to both freeze the system during or
immediately after the BIOS's device detection and thus prevent entry into the
setup utility until the SATA device(s) were disconnected.  I think it might have
a specific dislike for the DVD drive -- 'it' again being this lovely MSI
K9AGM-FID, which MSI doesn't even host BIOSes for on their US site.

DragonFly mustelid 1.11.0-DEVELOPMENT DragonFly 1.11.0-DEVELOPMENT #0: Sat Aug
18 01:42:44 EDT 2007     floid at mustelid:/usr/obj/usr/src/sys/MUSTELID2007  i386

dmesg snippet, the optical should appear on the fourth SATA port (ata3 'slave'):

atapci0: <ATI SB600 SATA300 controller> port
0xd800-0xd80f,0xdc00-0xdc03,0xe000-0xe007,0xe400-0xe403,0xe800-0xe807 mem
0xff6ffc00-0xff6fffff irq 2 at device 18.0 on pci0
ata2: <ATA channel 0> on atapci0
ata3: <ATA channel 1> on atapci0
atapci1: <ATI SB600 UDMA133 controller> port
0xff00-0xff0f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 irq 3 at device 20.1 on pci0
ata0: <ATA channel 0> on atapci1
ad0: 152627MB <WDC WD1600JB-98GVA0 08.02D08> at ata0-master UDMA100
ata1: <ATA channel 1> on atapci1

Suggestions for collecting useful debugging info always appreciated.  I don't
think a verbose boot had anything to say other than the normal response for no
devices detected.

messages: 3554
nosy: floid
priority: bug
status: unread
title: SATA no-go on ATI SB600 (K9AGM-FID)

DragonFly issue tracker <bugs at lists.dragonflybsd.org>

More information about the Bugs mailing list