lenovo R60 SMP/APIC_IO woes

Andrew Atrens atrens at nortel.com
Sun Apr 22 06:22:44 PDT 2007

Chris Turner wrote:
> Andrew Atrens wrote:
>> Symptoms are - bge0 watchdog timeouts, with ethereal I see TX's on the wire - but can't receive
>> any packets. sound doesn't work  pcm0:play:0:dsp0.0: play interrupt timeout, channel dead. for
>> the disk, controller is detected, but no disks found.
> Had similar problems with an acer F1000 with bge0
> (which processor wise is a turion X2 proc)

It is - a T2300

> did you try *with* SMP and *without* APIC_IO ?

Nope. Haven't tried that!

Hmm. I though APIC_IO was needed for SMP to work... I've never been 100% sure about how the two
are coupled though.

> that seemed to fix my bge lockups.
> havent tried sound, or similarly have not been able to get the hdd
> in non PATA compatibility. NATA didn't work for me but I've not yet
> been able to issue a coherent investigation report (or try -HEAD)..
> it might be worth a shot for you.

I'm using -HEAD and nata - works for me :)

> (for NATA, dig around on the wiki, there is something about what is needed)
>> Oh, EST is broken, too, but that's because the CPU runs at 1.66GHz and the cpu reports as -
>> hw.model: Genuine Intel(R) CPU           T2300  @ 1.66GHz
> not too worried on this because 'ACPI idle hook not enabled for SMP'..

Oh, I suppose. Is that what estd uses to decide when to slow stuff down ?

> my laptop is a work in progress.. but as long as theres power its ok :)
> good luck

thanks for the tip! :)



More information about the Bugs mailing list