Unexpected soft update inconsistency

walt wa1ter at myrealbox.com
Sun Jun 11 11:16:15 PDT 2006

YONETANI Tomokazu wrote:
> On Fri, Jun 09, 2006 at 09:35:38AM -0700, walt wrote:

> Does this problem persist even if you do the following:
> 1. reboot to single-user mode
> 2. run fsck at least once with an '-f' flag
> 3. go to multi-user mode
> 4. try building firefox

Yes, I always run fsck -f twice, to make sure that any errors
were really fixed -- and in this case they were fixed.

> Is this the same problem you posted on users@ last month?
> http://leaf.dragonflybsd.org/mailarchive/users/2006-05/msg00017.html
> if so, have you tried reinstalling gmake (as I wrote in the same thread)?

Yes, the same problem, and rebuilding gmake was the first thing
I tried -- it didn't change anything.  I made one big mistake in
my original post -- the build does *not* always stop in the same
place.  It does always stop just after printing 'leaving directory
foo', so the error is not completely random (just partly random).

I've spent all morning trying to get a ktrace of the problem
without success.  ktrace.out keeps using up all my free disk
space -- I made room for a 10GB partition, and that just got
filled up.  I've been running kdump on the result for 35 minutes
now and it just keeps scrolling by on my screen.  Dunno if I'll
be able to tell anything when it finally stops.  This process
does not scale well!

More information about the Bugs mailing list