apcupsd pkgsrc package install is slightly broken

Mark Cullen mark.r.cullen at gmail.com
Wed Jun 7 23:57:58 PDT 2006

walt wrote:
Mark Cullen wrote:
The problem: the rc.d script doesn't seem to get installed.

The following files should be created for apcupsd-3.8.6nb5:
       /etc/rc.d/apcupsd (m=0755)

Well, God knows I'm no expert, but I'm wondering if the script
got installed in /usr/pkg/etc/rc.d/ instead?
It wasn't in /usr/pkg/etc/rc.d/, but I assume you meant to say 
/etc/rc.d/ there? :-) Well spotted, I never checked there for it! I'll 
have a look at that one later.

When I first started using pkgsrc I tried to keep the FBSD ports
system installed at the same time.  I got hopelessly lost in the
details of where the rc and config files should be installed.
I'm still a bit uncertain about these details, actually, even
though I managed to get everything working just by trial-and-
It is a little different, but I do like how everything goes under /usr/pkg.

I remember (dimly) that doing a pkgsrc/bootstrap asks you where
you want certain things installed, like the rc.d directory, just
as one example.
It does?! When I ran the bootstrap script it just..... ran! Didn't ask 
me any questions :-)

Are there gurus out there who can give us the real facts?

More information about the Bugs mailing list