problems starting sshd at boot

George Georgalis george at
Tue May 24 11:00:53 PDT 2005

>On 5/24/05, George Georgalis <george at xxxxxxxxx> wrote:
>> My (only) 1.2.0_REL iso install doesn't start sshd at boot.
>> When I execute "sshd" I get the error:
>> sshd re-exec requires execution with an absolute path
>> "/usr/sbin/sshd" works as expected.
>> As a quick fix I tried changing the "name" line in /etc/rc.d/sshd
>> (name="/usr/sbin/sshd") but that seems not the rcng way, per errors.
>> Not sure why I don't see this in bugs or commits already... will make
>> world fix it? I've not been able to try, as I'm still trying to get
>> cvsupd working so I can cvsup from local sources.
On Tue, May 24, 2005 at 07:35:16PM +0200, Jonas Trollvik wrote:
>to enable sshd, add sshd_enable="YES" to /etc/rc.conf and type 
>/etc/rc.d/sshd start
>with the full path, that might be what it is complaining about. 
>The default rcng file works fine for me.

Thanks Jonas, that fixed it. My rc.conf was nearly empty, I may have
exited the installer prematurly or manually deleted the lines.

// George

George Georgalis, systems architect, administrator Linux BSD IXOYE cell:646-331-2027 mailto:george at xxxxxxxxx

More information about the Bugs mailing list