^Z during port build and hang?

YONETANI Tomokazu qhwt+dfly at les.ath.cx
Fri May 13 20:54:35 PDT 2005

On Sat, May 07, 2005 at 09:04:17AM -0700, Matthew Dillon wrote:
> :Recently I'm gettings hangs(on today's HEAD) if I press ^Z while
> :building a port.  It seems that I can correctly suspend the
> :processes for a few times, but after that, it just displayed
> :^Z and started ignoring ^Z or ^C(it responded to ^T and displayed
> :the hanging process and its state), and the load average slowly
> :grew up. I tried to switch to other virtual consoles or ssh from
> :another machine, but it was too late, I couldn't even log in.
> :I have no problem unless I tried to suspend the make process,
> :so this is basically
> :"Doc, it hurts if I do that -- don't do it, then"
> :problem :). Is anybody else seeing the similar thing?
>     It sounds like something is getting into a loop due to the signal
>     interaction.  The question is whether this is related to a kernel
>     issue or possibly a TLS issue.
>     If you renice up the shell your are running the make in, e.g.
>     'renice +20 $$', and get it into the same broken state, can you
>     login via ssh or another virtual console?  If you can manage to get
>     a 'ps' it might tell us what is looping.  If that fails, perhaps
>     breaking into DDB and generating a kernel core.

`renice +20 $$' didn't work. Pressing ctrl+T always shows [iowait]
after entering the hanging state. I put the kernel core on my leaf
account under a directory named ctrl-z. The hanging process(ctrl+T showed)
had pid 3311.


More information about the Bugs mailing list