dump or restore broken?

YONETANI Tomokazu qhwt+dfly at les.ath.cx
Sat Aug 27 18:53:31 PDT 2005

Has anything changed between 2005/07/23 and 2005/08/10 which might affect
the on-disk layout or something?  I'm running HEAD as of around 10th this
month, and I noticed that dump and/or restore has been broken
(if it's not gzip):

$ zcat rootfs-20050723.dump.gz | restore tf -
Tape is not a dump tape
$ zcat rootfs-20050810.dump.gz | restore tf -
Tape is not a dump tape
$ zcat rootfs-20050824.dump.gz | restore tf -
Level 0 dump of / on gzl.local:/dev/ad0s1h
Label: none
Dump   date: Wed Aug 24 23:56:29 2005
Dumped from: the epoch
         2      (null)
     21632      (null)
     21633      (null)
     25822      (null)
     25823      (null)

The dump files are always named after the date of the dump.  I always dump
and restore the root filsystem before running installworld, and I remember
it worked, so I'm sure rootfs-20050723 and rootfs-20050810 are dump'ed on
pre-20050810 system.  I haven't tried restoring the newest dump file yet,
so the "(null)" may be a separate bug in the listing routine.


More information about the Bugs mailing list