Compaq R3000Z problem

Matthew Dillon dillon at
Tue Jun 22 22:51:02 PDT 2004

:Jung-uk Kim wrote:
:> Hi,
:> I just got a Compaq R3000Z laptop.  I was hoping that I could use
:> FreeBSD and DragonFlyBSD on it but it doesn't boot at all.  I searched
:> FreeBSD PR and I found this:
:> I wasn't ready to give up yet, so I tried OpenBSD/amd64 3.5,
:> NetBSD/amd64 2.0-Beta, Gentoo/amd64 2004.1, Mandrake/amd64 10.0RC2,
:> FreeBSD 3.5.1, 4.x, 5.x (i386 and amd64 snapshots), and finally,
:> DragonFlyBSD snapshot - yes, it took me hours to try them all. :-(
:> All of FreeBSD's and DragonFlyBSD failed (with or without acpi/safe
:> mode) and everything else worked flawlessly.  I feel really bad now
:> because there is no easy way to debug this kind of failure.  I know that
:> something's going on between loader and kernel init but that's all I can
:> see.  Is there any way that I can debug this issue or does anybody know
:> what may cause this?
:I sorry that I reply to myself.
:I found somebody else had the same issue.
:Just like he said, it powers down immediately when it displays first \ 
:from \|/-.
:Jung-uk Kim

    This is still in the boot loader, and Dragonfly is using FreeBSD-5's 
    boot loader so it is not unexpected that it would fail in the same
    way that the other FreeBSD's fail.  That it also fails in FreeBSD-4
    seems to indicate that the problem has been around for a while.

    We are not going to be able to fix this for the release, but it is
    becoming increasingly clear that I am going to have to rip open the
    boot loader at some point and implement the missing emulations.
    I sometimes have 'odd' BTX failures on my AMD64 boxes as well, so
    you are not alone.  I *KNOW* that bootloader is doing something wrong
    somewhere, I just don't know where.

					Matthew Dillon 
					<dillon at xxxxxxxxxxxxx>

More information about the Bugs mailing list