q3ded revisited

Matthew Dillon dillon at apollo.backplane.com
Mon Apr 5 18:18:45 PDT 2004

:I just re-installed DF from scratch, incl. cvsup, etc. to see the
:q3ded server running, but I'm afraid it's still not working.
:The NET_SendPacket error is gone, but clients are still unable to
:connect to q3ded. "qstat -q3s localhost" shows a status of "DOWN",
:which is clearly incorrect, since q3ded is running as a daemon.
:There's no output, so for now I just can't give any more details
:today; I'm off to bed in a minute.

    It's quite possible that there are other issues.  Just today we fixed
    another TCP related connection bug, if your sources are from slightly
    earlier then you should cvsup again and rebuild your kernel (I give 
    that a 50-50 chance of being the problem).  If that isn't it then there
    must still be some outstanding linux emulation issues, the only way
    to figure out what is to do some investigation.

    Once you resolve the second set of issues you state below you should
    be able to check to see what ports the server is listening on with
    netstat -tn and other utilities.  If it does appear to be listening
    on the correct ports you could ktrace the running server during
    just the bit where you attempt to connect into it.  e.g.

    # ps (once you get it working)
    (figure out the pid of the server)
    # ktrace -i -p pid		(ktrace the live server process)
    (attempt to connect to the server)
    # ktrace -C			(stop ktracing the live server process)
    (send me the ktrace.out file as before)

:Another effect on my scratch-build system is, that I get the error
:"kvm_open: proc size mismatch (66312 total, 1224 chunks)
:top: out of memory"
:when I try to start "top". I just did a makeworld an makekernel as a
:test, the latter with GENERIC cfg.
:Same error occurs when trying to execute "ps".
:Not quiet a q3ded issue, but I need to tell someone... :-)

    This occurs when your installed world is not in synch with your
    installed kernel.  Generally when you upgrade a system you need to
    upgrade both the kernel and the world.  e.g.

    cd /usr/src
    make buildworld			(or make quickworld once you've
					 done at least one buildworld)
    make buildkernel KERNCONF=<blah>
    make installkernel KERNCONF=<blah>
    make installworld
    make upgrade

					Matthew Dillon 
					<dillon at xxxxxxxxxxxxx>

More information about the Bugs mailing list