ad0: read interrupt arrived earlyad0: read error detected (too) late

YONETANI Tomokazu qhwt at
Wed Nov 19 17:46:35 PST 2003

On Wed, Nov 19, 2003 at 12:20:16PM -0800, Matthew Dillon wrote:
> :Hello.
> :Have you ever seen this message appeared on DragonFly's console?
> :
> :The first time I've noticed this was November 14th, when I was
> :running fsck on my biggest partition. At the time I thought this
> :either because the drive was broken, or my laptop was broken.
> :Today I've upgraded one of FreeBSD-STABLE machines to DragonFly,
> :and when I ran a script, it suddenly slowed down, and when I managed
> :to terminate X, there were bunch of the error message(in the subject
> :of this message) on the console. The script which triggered the
> :symptom basically does something like this(as non-root user):
> :
> :$ find /usr/src -type f | xargs -n 300 md5 -r
> :
> :the symptom happened when I redid an installworld of DragonFly.
> :Finally I've reverted the machine to FreeBSD-STABLE, and tried the
> :same script but it finished without the errors, so I suppose it's
> :not hardware failure.
> :
> :Unfortunately, I didn't configure syslogd to keep /var/log/messages
> :for months, so I'm not sure when this first began, but it seems that
> :the kernel built from November 11th's source had this problem. What
> :makes me puzzled is that `make -j3 buildworld' doesn't trigger this
> :problem, but rather running fsck on a big partition, or doing some
> :disk I/O intensive processes(especially when it's doing a READ from
> :the disk?) would do.
> :
> :Regards.
>     I have never seen this before, but looking at the code it only
>     occurs during a PIO mode operation.  Do you see any other 
>     messages, like 'DMA problem fallback to PIO mode', or is your
>     system just doing PIO by default?

I forgot to mention that when I saw the error message while installworld
is running, I read the ata code too and changed the mode manually into DMA
mode, then installworld continued without error messages. I've zgrep'ed my
/var/log/messages*, but I couldn't find any fallback messages, only
`read interrupt arrived early...' messages. So I have no idea when it
fell back to PIO mode.

My laptop PC runs in UDMA66 by default, 256Mbytes of RAM, running UP kernel.
Another machine(mentioned above) in UDMA100, also 256Mbytes of RAM, running
SMP kernel (but at the time I saw the error messages, SMP was not active,
and this machine does not support HTT, and has only one processor).

More information about the Bugs mailing list