ad0: read interrupt arrived earlyad0: read error detected (too) late

YONETANI Tomokazu qhwt at
Wed Nov 19 03:26:26 PST 2003

Have you ever seen this message appeared on DragonFly's console?

The first time I've noticed this was November 14th, when I was
running fsck on my biggest partition. At the time I thought this
either because the drive was broken, or my laptop was broken.
Today I've upgraded one of FreeBSD-STABLE machines to DragonFly,
and when I ran a script, it suddenly slowed down, and when I managed
to terminate X, there were bunch of the error message(in the subject
of this message) on the console. The script which triggered the
symptom basically does something like this(as non-root user):

$ find /usr/src -type f | xargs -n 300 md5 -r

the symptom happened when I redid an installworld of DragonFly.
Finally I've reverted the machine to FreeBSD-STABLE, and tried the
same script but it finished without the errors, so I suppose it's
not hardware failure.

Unfortunately, I didn't configure syslogd to keep /var/log/messages
for months, so I'm not sure when this first began, but it seems that
the kernel built from November 11th's source had this problem. What
makes me puzzled is that `make -j3 buildworld' doesn't trigger this
problem, but rather running fsck on a big partition, or doing some
disk I/O intensive processes(especially when it's doing a READ from
the disk?) would do.


More information about the Bugs mailing list