OpenOffice anyone?

Matthew Dillon dillon at
Sun Dec 7 10:13:14 PST 2003

:> I'm curious if anyone has tried to get OpenOffice to build?  I'm giving
:> it a whirl now.  The first problem I ran into is that it depends on
:> gcc33, which fails to build do to a missing header (machine/ansi.h,
:> iirc).  "pkg_add -r" got it gcc33 installed though.  It appears to be
:> successfully building jdk14 now.  I'll report back with the result in
:> the morning.
:> Should there be a separate forum to discuss ports issues?
:> Adam
:It doesn't build :-(
:It dies while trying to build mozilla in the OO source tree.  
:configure:7470:35: X11/extensions/XIElib.h: No such file or directory
:And then:
:In file included from /usr/X11R6/include/X11/Xlib.h:51,
:                 from configure:7514:
:/usr/local/lib/gcc-lib/i386-portbld-freebsd4.9/3.3.2/include/sys/types.h:57:72: sys/inttypes.h: No such file or directory
:In file included from /usr/X11R6/include/X11/Xlib.h:51,

    Yah, I kinda expected that.  I think we've stretched ports about as
    far as we can with hacks.  I don't think OpenOffice is going to work
    until we create a new ports/packaging system and bring it in under


More information about the Bugs mailing list