[DragonFlyBSD - Bug #2961] (Closed) undefined reference to 'pthread_cancel' building multimedia/ffmpegthumbnailer

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Thu Oct 27 00:25:30 PDT 2016

Issue #2961 has been updated by zrj.

Status changed from New to Closed

Closing, issue is Dports specific.
Missing link dep fix was pushed to DeltaPorts.
Thanks for testing.

Bug #2961: undefined reference to 'pthread_cancel' building multimedia/ffmpegthumbnailer

* Author: davshao
* Status: Closed
* Priority: Normal
* Assignee: zrj
* Category: 
* Target version: 
I am classifying the following as a master source regression and not a dports issue because multimedia/ffmpegthumbnailer was building until yesterday without issue in a hacked version of pkgsrc I have been using.  Some change from October 25 breaks building both on pkgsrc and dports.

To demonstrate the problem using dports, update to master source through:

commit 62a4e7957a736b4de38938b02fa7eb9b45bc5d0d
Date:   Tue Oct 25 23:04:45 2016 +0200

    if_iwm - Switch arguments from iwm_node* to iwm_vap* in if_iwm_power.c.

Now build dports git, xorg, xfce4 from scratch using:

make clean && make NO_DIALOG=yes install clean

Now try building for multimedia/ffmpegthumbnailer.  I would guess one would obtain an error similar to:

CMake Warning:
  Manually-specified variables were not used by the project:



--- ffmpegthumbnailer ---
[ 83%] Linking CXX executable ffmpegthumbnailer
/usr/local/bin/cmake -E cmake_link_script CMakeFiles/ffmpegthumbnailer.dir/link.txt --verbose=1
/usr/bin/c++    -pipe -g -O2 -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -std=c++11  -pipe -g -O2 -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include   CMakeFiles/ffmpegthumbnailer.dir/main.cpp.o  -o ffmpegthumbnailer  libffmpegthumbnailer.so.4.11.0 /usr/local/lib/libavformat.so /usr/local/lib/libavcodec.so /usr/local/lib/libavutil.so /usr/local/lib/libswscale.so /usr/local/lib/libjpeg.so /usr/local/lib/libpng.so -lz -Wl,-rpath,/usr/obj/dports/multimedia/ffmpegthumbnailer/.build:/usr/local/lib 
libffmpegthumbnailer.so.4.11.0: error: undefined reference to 'pthread_cancel'
collect2: error: ld returned 1 exit status

The /etc/make.conf I used is a simple:

# cat /etc/make.conf



You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list