[DragonFlyBSD - Bug #2686] kernel 3.8.1 freezes and panics at boot

bugtracker-admin at leaf.dragonflybsd.org bugtracker-admin at leaf.dragonflybsd.org
Thu Jun 26 01:14:25 PDT 2014

Issue #2686 has been updated by peeter.

OK sorry, here are excerpts from booting master. (I will try to get a video shot in a couple of hours and report back.)

--- --- 
SMAP. . .
SMAP. . .
Copyright. . .
Slab ZoneSize set to 128KB
Leaving critical section, allowing interrupts
ACPI FADT: SCI irq 9, conform/conform
DragonFly v. . .
Calibrating clock(s) . . .
. . .
avail memory = . . . 
ACPI MADT: LAPIC address 0xfee00000, flags 0x1
ACPI MADT: BSP apic id 0
ACPI MADT: cpu id 0, apic id 0
ACPI MADT: cpu id 1, apic id 1
lapic: divisor index 0, frequency 132667255 Hz
SMP: CPU0 apic_initialize():
        lint0: 0x00010700 lint1: 0x00000400 TPR: 0x00000000 SVR: 0x000001ff

. . . not sure about this---went by too fast . . .

crypto: cryptosoft0 registers alg 14 flags 0 maxoplen 0

. . . lots of crypto here . . .

cryptosoft0: <software crypto> [attached!] on motherboard  
aesni0: No AESNI support.
padlock0: No ACE support. 
rdrand0: No RdRand support. 
acpi0: <APPLE Apple00> [tentative] on motherboard
ACPI: All ACPI Tables successfully acquired
PCIe: Memory Mapped configuration base @ 0xf0000000, bus [0, 255]
PCIe: Using Memory Mapped configuration



Bug #2686: kernel 3.8.1 freezes and panics at boot

* Author: peeter
* Status: New
* Priority: Normal
* Assignee: profmakx
* Category: 
* Target version: 
DFly 3.6.x x86_64 boots and runs fine on my laptop
(macbookpro5,5), the 3.8.1 install iso freezes at boot. (acpi/ehci
disabled in both cases.) These are the last lines before freezing

--- ---
pci0: <processor> (vendor 0x10de, dev 0x0aa3) at device 3.5 irq 14
ohci0: <nVidia nForce MCP79 USB Controller> [tentative] mem
0xd3488000-0xd3488fff irq 11 at device 4.0 on pci0
ohci0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xd3488000

Since 3.6.x boots and runs fine (with acpi disabled) on this machine, 
I thought the freeze was related to the new usb. So upgraded
3.6.2 to 3.8.1 via git, did buildworld and buildkernel with WANT_OLDUSB=yes
in /etc/make.conf. The system now panics at boot, showing

fwohci0: <1394 Open Host Controller Interface> [tentative] mem
0xd3100000-0xd3100fff irq 7 at device 0.0 on pci4
fwohci0: latency timer 0 -> 32.
fwohci0: cache size 64 -> 64.
fwohci0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xd3100000

and then giving the db> prompt but because it freezes, or at least the
keyboard freezes, I can't call dumpsys. So unfortunately there's no
crash dump. I could then boot and run the system with the old 3.6.2

Further: since fwohci0 was the last line in the previous message, I 
recompiled the 3.8.1 kernel without firewire: 

# FireWire support
#device		firewire	# FireWire bus code
#device		sbp		# SCSI over FireWire (Requires scbus and da)
#device		fwe		# Ethernet over FireWire (non-standard!)

This causes kernel panic much later in the boot at umass and gives a db> prompt
that is functional but call dumpsys returns only 0 and there is no still no core dump. 

I also tried booting FreeBSD 10.0 to see how the (new) usb stack
fares. It boots fine. I attach the verbose dmesg for both FBSD 10 and
DFly 3.6.2 just in case.

I wonder if there's a way to get a debug or dumpsys for 3.8? Could
vkernel help or is it isolated from hardware?




DFly-3.6-verbose.dmesg (41.3 KB)
FBSD-10.0-verbose.dmesg (61.6 KB)
dfly-3.6-x86_64-macbookpro5,5-acpidump-b.tgz (10.4 KB)

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://bugs.dragonflybsd.org/my/account

More information about the Bugs mailing list